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Notice and Disclaimer 
This manual’s sole purpose is to assist installers and/or users in the safe and 
efficient installation and usage of the system and/or product, and/or software 
described herein. 

BEFORE ATTEMPTING TO INSTALL AND/OR USE THE SYSTEM, THE INSTALLER AND 

THE USER MUST READ THIS MANUAL AND BECOME FAMILIAR WITH ALL SAFETY 

REQUIREMENTS AND OPERATING PROCEDURES. 
 The system must not be used for purposes other than those for which it 

was designed. 

 The use of the software associated with the system and/or product, if 
applicable, is subject to the terms of the license provided as part of the 
purchase documents. 

 ROSSLARE exclusive warranty and liability is limited to the warranty and 
liability statement provided in an appendix at the end of this document. 

 This manual describes the maximum configuration of the system with the 
maximum number of functions, including future options. Therefore, not 
all functions described in this manual may be available in the specific 
system and/or product configuration you purchased.  

 Incorrect operation or installation, or failure of the user to effectively 
maintain the system, relieves the manufacturer (and seller) from all or any 
responsibility for consequent noncompliance, damage, or injury. 

 The text, images and graphics contained in the manual are for the 
purpose of illustration and reference only. 

 All data contained herein subject to change without prior notice. 

 In no event shall manufacturer be liable for any special, direct, indirect, 
incidental, consequential, exemplary or punitive damages (including, 
without limitation, any and all damages from business interruption, loss of 
profits or revenue, cost of capital or loss of use of any property or capital 
or injury). 

 All graphics in this manual are for reference only, some deviation between 
the image(s) and the actual product may occur. 

 All wiring diagrams are intended for reference only, the photograph or 
graphic of the PCB(s) are intended for clearer illustration and 
understanding of the product and may differ from the actual PCB(s).
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1. Introduction 
Thank you for purchasing Rosslare’s DigiTool® system. This is the installation 
and user manual for the GS-01 DigiTool Reports Lite software package, 
intended for a single PC station. 

The GS-01 software for the PC includes many advanced features provided 
within a user-friendly PC interface with new icon based toolbars and menu 
driven selections. 

1.1 Features 

 User restricted access levels 

 Master or Regular User 

 Programmable features  

 Multiple users  

 Multiple sites 

 Multiple readers (reader lockout) 

 Multiple tours with times  

 Built-in integrated database 

 Store all downloaded data  

 Tour reports 

 Exception reports 

 Incident reports 

 Reader download reports 

 System hardware list report 

 Patrol schedule report 

 Database report  

 Uploading and downloading controls 

 Program reader options 

 Program reader date and time 

 Erase reader DATA (clear reader) 

This GS-01 DigiTool Reports Lite Software is included with the DigiTool kit, and 
is a separate software package for advances applications. 

The GS-01 DigiTool Reports Lite Software provides advanced features to 
enable the PC to act as a central data station. 
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1.2 Hardware Compatibility 

The GS-01 software is compatible with the following existing products in the 
DigiTool Digital Data Acquisition family of products from Rosslare Enterprises 
Ltd: 

 GC-01 – Digital iButton Reader 

 GC-02 – Docking Charger with connection to the PC 

 GC-03 – Docking Charger only 

 GA-01 – Location Tag (1 Location iButton) 

 GA-02 – Event Book (10 Events iButtons) 

1.3 Contents of Software Package 

The Rosslare DigiTool Reports Lite kit includes a DigiTool GS-01 Reports Lite 
Software CD–ROM and a serial number for one license. 

1.4 The Hardware Elements  

The DigiTool Reports Lite Software is fully compatible with the GCK-01 Lite kit 
(which includes the GS-01 Reports Lite Software). GS-01 Reports Lite Software 
works with the following Rosslare DigiTool products: 

1.4.1 GC-01 DigiTool Digital ID Reader 

 
GC-01 is the ID Tag reader for the DigiTool system. Using this reader, data 
can be stored on site in a secure robust data reader, and then 
downloaded to the PC later for the Data Analysis and Reports. 

1.4.2 GA-01 DigiTool Location Tag Digital ID 
Figure 1: GA-01 Front 

 
 

Outside cover to 
hide and protect 

the screws and the 
wall mount. 

Area to stick a 
label to 

identify the 
location 

Metal button is 
protected 

inside a recess 
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Figure 2: GA-01 Back 

 
The GA-01 Location Tag is enrolled in the PC Software, and then attached 
permanently to the specific remote location which needs to be monitored 
periodically by the DigiTool System. 

Rosslare’s GA-01 Location Tags are designed to be used with the DigiTool 
System. The GA-01 Location Tag comes with a two piece plastic Snap-On 
housing which is used to house the iButton Chip Tag rigidly in its place. 

The GA-01 base with the tag can be mounted onto hard surfaces with up 
to four screws and added channels for using EPOXY glue. Once the 
locations are enrolled in the GS-01 computer software, and are in the 
system, they can be mounted onto the location where they are intended. 

The GA-01 features a thick plastic top cover, which hides the screws and 
protects the iButton Chip Tag from damage by protecting the perimeter 
of the tag. Place a label on the top cover if desired. 

1.4.3 GC-02 DigiTool Base and Charger 

 
The GC-02 DigiTool Base, Charger is the docking station and Tag Reader 
used for docking the GC-01 Reader when it is not in use. This serves the 
function on PC interconnection for uploading and downloading the 
reader, as well as a charger for the reader. 

 

Hole for 
mounting to wall 

with screw 

Hole for mounting to 
wall with screw 

Dallas Semiconductor 
Coded Button Snap in 

Optional 
additional screw 
mounting hole 
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1.4.4 GA-02 DigiTool 10-Event Wallet 

 
The Event Wallet is a compact, rugged and robust booklet consisting of 
10 Event Tags, which can be programmed in the PC to represent real time 
events. The reader can read off the Tags on the GA-02 event wallet. 

1.4.5 AT-32B DigiTool Keychain ID Tag 

 
The User tag is an optional iButton ID tag placed on a key-chain type 
plastic housing and has applications for cases that the location involves 
meeting a person, and getting the feedback from that person. 

1.4.6 GA-06 DigiTool Leather Reader Belt Holster for GC-01 Reader 

 
This rugged leather holster for carrying the GC-01 Reader is made of 
tough thick leather that lasts a lifetime of regular use. The GA-06 is the 
ideal way to carry around the reader for touring. 

1.5 Important Information before Getting Started 

Before you install the DigiTool System Software on your PC, you need to turn 
off the power to your computer and remove any serial port device from either 
9-pin serial ports, since the DigiTool system requires one free serial COM port 
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to operate with the PC software. Plugging and unplugging cables to your 
computer's serial port while the computer is running can damage the port. 

This applies to installation of any Rosslare DigiTool System Software (GS-01 
Reports Lite or GS-02 Reports Professional). 

1.5.1 Connecting the AC/DC Adapter and Serial Cable to the Docking 
Station 

Power to the DigiTool System is an AC/DC adapter that provides 12 volts 
regulated DC voltage from international AC voltage. The AC/DC adapter 
provided from your dealer should match the type of socket and voltage of the 
country of sale. 

To connect the AC/DC adapter and serial cable to the docking station: 
1. Turn off your computer. 

2. Remove the DigiTool GC-01 reader from the GC-02 base docking station. 

3. Plug the AC/DC adapter to a wall outlet. Make sure the AC/DC adapter is 
12 VDC. 

4. Connect one end of the 9-pin serial cable to the port at the back of the 
GC-02 Base unit (Figure 3). 

Figure 3: Connections to the DigiTool GC-02 Base 

 
5. Connect the other end to the PC serial port. 
6. Connect the 12 VDC plug into the socket on the back of the GC-02 base. 

7. After the power cable is connected, make sure that the LED indicator on 
the front of the GC-02 is on and that the color is orange. 

 

Once the GC-01 reader is placed into the GC-02 base, the color of the LED 
changes from orange to red (if the reader is charging) or to green (if reader is 
fully charged). 

Once the above instructions have been followed, you are ready to install the 
GS-01 PC Software as described in Chapter  2. 

DC Power 

PC Serial Cable 
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2. Installing the DigiTool GS-01 
Software 

The DigiTool GS-01 software package requires software to be installed on the 
hard disk of the PC and into the physical working memory of the PC. 

2.1 Minimum PC Requirements 

 Windows XP, 7 (32-bit only) 

 (**Windows is a registered trademark of Microsoft Corporation, all rights 
reserved Microsoft) 

 CD-ROM drive  

 16 MB RAM 

 Serial Port (9-pin connector) and 1 Free COM Port 

 Approximately 20 MB Hard Disk Space 

2.2 Installing the Software 

The installation of the DigiTool GS-01 from the CD-ROM is a mostly automated 
process done by an installer program. 

To install the software: 
1. Place the CD-ROM in the CD-ROM drive and open the drive window on 

the screen. 

2. Find the file named Setup.exe and double-click the file. The setup screen 
opens. 
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3. Click OK. The next setup screen opens. 

 
4. Click the icon button to accept the default location for the installation, or 

first click Change Directory to specify your own custom location for the 
program files and database to be placed on your PC. 

The installation creates a directory, copies all program files into the 
selected directory, and creates the DigiTool icon on the Windows Start 
menu. 

The Choose Program Group screen opens. 

 
5. Click Continue to use the default Program Folder name to be used for 

your Windows Start menu button or first enter a new name. 

The progress of the installation process is shown. 

6. When the installation process completes, a confirmation screen opens. 

7. Click OK. 

The GS-01 software package is now installed onto your PC and is ready to be 
configured and used. 
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3. Running the Software on the PC 
3.1 Logging In 

Once the installation process is complete, you can run the program. 

To log in: 

1.  Double-click the DigiTool Reports Lite icon ( ) on the desktop or click 
Start > Programs > DigiTool Reports Lite. 

 

Make sure that all of the hardware is connected to the PC and that the power 
to the hardware is supplied; otherwise, there is no connection. 

After initiating the program, the PC loads all databases and the logon 
screen opens. 

 
2. Select the User for logging in, either Master or (standard) User. 

3.  Enter the default login passwords to access the program as follows: 

 Master User: Default Password is [master] 

 Regular User: Default Password is [user] 

4. Press OK. 
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Once you’ve entered the correct login information, the main screen opens. 

 
Depending on the security access level of the user logging on (Master or User), 
the Reports Lite Software allows different levels of use. 

Table 1 summarizes the functionality of the two user levels. 
Table 1: User Levels 

 Options Download Erase 
Reader 

Archive 
Database 

Programming Reports 

Master Yes Yes Yes Yes Yes Yes 

User
  

No Yes Yes No No Yes 

This manual describes the Master level functionality and thus includes all 
features of the software. 

From this main screen, it is possible to access all of the functions of the Reports 
Lite Software package. 

The first time the program is executed, all of the settings are at default and it is 
necessary to customize and install the elements of the system. This requires 
setting up and programming all of the necessary customization you need by 
defining and/or enrolling sites and locations, events, tours, and readers, as 
described in Chapter  4. 

The initial setup process time is relative to the size and type of application for 
the end user, and therefore depends on the number of users, locations, sites, 
events, and so on. 



Setup Process 

18 GS-01 DigiTool Reports Lite Software Manual 

4. Setup Process 
The process of initially setting up the software is done by using the Setup icon 
on the main toolbar. 

 
The Setup menu consists of four tabs (Figure 4). 

Figure 4: Setup Window 

 
Each of these tabs is described in the following sections: 

 Sites and Location Tags 

 Event Books and Events 

 Tours 

 Readers 

Once all of the setup steps are completed, the entire system can be tested 
within the office, and during this test time, the PC software and hardware can 
be tested and training can be done. Please make sure to label the locations 
appropriately with numbers or names of the locations, so that once the 
software is set up, the correct location tag can be permanently mounted at the 
correct location. 

 

These functions can be programmed only by the Master login password. 
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4.1 Sites and Location Tags 

The GS-01 PC software enables the locations to be arranged in groups of sites. 
For example, a site can be a large building, and the locations can be held 
within that building. 

The GS-01 can learn thousands of locations and is not limited to any number 
of sites. Therefore, it is important to order your additional tags ahead of time 
while planning for the site construction. 

Using the Sites tab, you can add, edit or delete sites and locations. 

4.1.1 Adding a New Site 

To add a new site: 

1. Click the Setup icon ( ) on the toolbar. The Sites screen appears with 
the Sites tab selected by default. 

 
2. Click Add. 

A new site appears under the sites list. 

The properties of an existing site can be edited at any time (see Section  4.1.3). 

4.1.2 Adding a Location within a Site 

Within each site that you create, you need to add locations that are each 
assigned GA-01 location tags. Each location tag is placed in a single location 
and is used as a marker for any type of event observation at that location. 

To add a location: 
1. Choose an existing site. 

2. Click Edit to open that site’s Edit Site window. 
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3. Click Add. The Add New Location window opens. 

 
4. Remove the reader from the docking base. 

5. Enroll a new location tag (make sure that it is not already used for another 
site) to the PC by contacting it to the tag reader on the GC-02 base which 
is connected to the PC. 

 
6. To manually enter the Tag ID, click Manual Entry and enter the ID tag as 

read off of the ID button. 

As soon as a valid location tag has been presented to the GC-02 base, you 
see that the software accepts that location to the system. 

 

Touch the ID 
Button Here 
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If a location tag has already been used, the GS-01 software package alerts 
you by showing the following screen. 

 
7. Enter any custom data to the location such as its Name and Description. 

8. Click OK. The location now appears in the list of locations. 
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9. Repeat this procedure to add additional locations within this site. 

4.1.3 Editing an Existing Site 

Once you have set up a site and its locations, you can edit its properties. 

To edit an ex isting site: 
1. From the Site list, select a site. 

2. Click Edit. The Edit Site window opens. 

You can rename the Site name and enter a description for the site in the 
fields provided. 

In addition, you can edit and delete existing locations. 

4.1.3.1 Editing an Existing Location within a Site 

To edit and ex isting location: 
1. While in the Edit Site window, select a location from the list. 

2. Click Edit. 

3. Edit the information as needed. 

4.1.3.2 Deleting an Existing Location within a Site 

To delete and ex isting location: 
1. While in the Edit Site window, select a location from the list. 

2. Click Delete. A confirmation message appears. 

3. Click Yes to confirm. 

4.1.4 Deleting an Existing Site 

 

When you delete a site, all existing locations in that site are deleted as well. 
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To delete an ex isting site: 
1. From the Site list, select a site. 

2. Click Delete. A confirmation message appears. 

3. Click Yes to confirm. 

Once the site and the locations within are deleted from the software, they can 
be re-used when setting up any additional sites. 

4.2 Event Books and Events 

 

This function can be programmed only by the Master login password. 

On the GS-01 software, you can add multiple event books onto the system, 
depending on the number of patrols being performed simultaneously. There 
can be an unlimited number of event books on the system, with an unlimited 
number of events per event book used in the software. 

Each event book can be used across the multiple sites that are being 
monitored, with multiple readers at the same time. 

Event books can be set up according to the different applications, such as a 
Day Time Tour Events, a Night Time Tour Events Book or an individual Event 
Book for Every Security Patrol Guard. 

The GS-01 software enables the events to be arranged in groups of event 
books. For example, there may be an event wallet for a standard search and 
another wallet with a specified search. 

This function enables the system to function even when using several wallets. 
Setting up the event books and events is done using the Events Books tab. 
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When this tab is selected, then you can add, edit or delete sites. 

4.2.1 Adding a New Event within an New Event Book 

To create an event book: 

1. Click Setup icon ( ) on the toolbar. 

2. Click the Events Book tab. 

3. Click Add. 

A new event book appears under the event book list. 

The properties of an existing event book can be edited at any time (see Section 
 4.2.3). 

4.2.2 Adding an Event within an Event Book 

Within each event book that you create, you can add events. 

To add a location: 
1. Choose an existing event book. 

2. Click Edit to open that event book’s Edit Event Book window. 
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3. Click Add. The Add New Event window opens. 

 
4. Present the appropriate ID Tag to the Docking station reader (make sure 

the reader is not docked). After presenting the tag from the GA-02 event 
book, the tag is read. 

 

 

 

Touch the ID 
Button Here 
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If the tag has already been used by another event, then you see the following 
error message. 

 
5. Enter any custom data to the location such as its Name and Description. 

6. Click OK. 

7. Repeat this procedure for all additional events within this event book. 

After you have set up an event book, the GS-01 shows all of the information 
within that event book, as seen in Figure 5. 

Figure 5: Example Event Book 

 
4.2.3 Editing an Existing Event Book 

Once you have set up an event book and its events, you can edit its properties. 

To edit an ex isting event book: 
1. From the Event Book list, select an event book. 

2. Click Edit. The Edit Event Book window opens. 
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You can rename the Event Book name and enter a description for the 
event book in the fields provided. 

In addition, you can edit and delete existing events. 

4.2.3.1 Editing an Existing Event within an Event Book 

To edit and ex isting location: 
1. While in the Edit Event Book window, select an event from the list. 

2. Click Edit. 

3. Update the information as needed. 

4.2.3.2 Deleting an Existing Event within an Event Book 

To delete and ex isting location: 
1. While in the Edit Event Book window, select an event from the list. 

2. Click Delete. A confirmation message appears. 

3. Click Yes to confirm. 

4.2.4 Deleting an Existing Even Book 

When you delete an event book, all existing events in that event book are 
deleted as well. 

To delete an ex isting event book: 
1. From the Event Book list, select an event book. 

2. Click Delete. A confirmation message appears. 

3. Click Yes to confirm. 

4.3 Tours 

Touring is a special feature of the DigiTool Reports Lite software. Inside the 
software, the Master user can set up a tour, which is actually a schedule for 
checking different sites during any 24-hour period. 

Setting up a new tour consists of creating a new tour, and then configuring all 
of the sites and locations to visit, and the time tolerance between each point. 

This enables the Central Station to have a pre-made schedule for the tours, 
and to have the user make the rounds according to the tour instructions. 
Setting up the tours is done using the Tours tab. 
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4.3.1 Adding a New Tour Route 

To add a new tour: 

1. Click the Setup icon ( ) on the toolbar 

2. Click the Tours tab. 

3. Click Add. 

A tour appears under the tours list. 

4.3.2 Editing an Existing Tour 

Once you have created a tour entry, you can set up the tour’s sequence.  

Editing the tour involves programming the schedule of the tour and the route 
to follow into the PC software so that the tour schedule can be generated and 
printed. 

In addition, a pre-defined tour schedule is essential for printing reports such as 
tour reports, schedules, or tour exceptions. 

However, you must know the following parameters before you can edit a tour: 

 Tour start time 

 Time interval between sites (travel time by car) 

 Time intervals between locations within the sites 
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To set up a tour’s sequence: 
1. From the Tour list, select a tour. 

2. Click Edit. The Customize Tour Sequence window opens. 

 
3. Enter a name and description of the tour. 

4. From the Site dropdown, choose a site you wish to include in a tour. 

5. In Tour Start Time, enter the start time of the tour. 

6. In Tolerance, enter the time needed between locations. 

7. In the Available Locations area, select a location and click Add to include 
it as part of the tour. 

8. Repeat Steps  4 through  7 for each site and associated location(s) you wish 
to add to the tour. 

9. Click Save. 

10. Repeat the entire procedure for each tour. 

4.3.3 Deleting a Tour 

To delete an ex isting tour: 
1. From the Tour list, select a tour. 

1. Click Delete. A confirmation message appears. 

2. Click Yes to confirm. 
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4.3.4 Copying a Tour 

To copy  a tour: 
1. From the Tour list, select a tour to copy. 

2. Click Tour Copy. The Select Tour to copy screen opens. 

 
3. From the Tour to copy dropdown, select a tour to copy. 

4. Click OK. 

A copy of the selected tour appears in the list of tours. 

4.4 Readers 

Enrolling the readers in the software and thus establishing a link between 
every reader and the system provides added security to the system. Each reader 
is given a PC code, which prevents unauthorized use of any non-system reader 
with the database. 

This means that no other reader can be substituted for the actual registered 
reader. If an unauthorized reader is used to falsify data, the system detects this 
and considers the reader as void, and therefore does not upload or download 
any of that reader’s data. This PC code enables the software to identify the 
source of the reader and to choose to accept or reject the data from that 
reader. 

Each GC-01 reader’s code is random and is pre-programmed in the factory 
during manufacturing. This is the individual serial number on every reader. 

 

When the DigiTool system is sold across different market regions, Rosslare is 
able to customize a part of the reader code for any exclusive distribution rights. 
This thereby locks out any systems that do not come from that particular 
distributor with the system. 

This feature adds enhanced market confidence that compatibility between any 
outside readers from another exclusive market segment does not interfere with 
the exclusivity of Rosslare distributors. 

This feature is controlled only from the factory. 
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4.4.1 Enrolling a New Reader to the Software System 

You must enroll each reader in the software program. 

To enroll a reader: 

1. Click the Setup icon ( ) on the toolbar. 

2. Click the Readers tab. 

 
3. Be sure the reader is not in the docking station. 

4. Click Add. The Add New Reader window opens. 

 
5. Place the reader in the docking base station. 

6. Click READ ID. The reader 

The system begins enrolling the reader ID code into the program. 
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Do not remove the GC-01 reader from the docking station until this step is 
finished. 

If the reader is accepted into the system, the following screen opens. 

 
If the reader is not accepted, then you see the following error message. 

 
7. Enter any the description of the reader. 

8. Click OK. 
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4.4.2 Editing an Existing Reader 

Once you have set up a reader, you can change its description. 

To edit a reader’s description: 
1. From the Readers list, select a reader. 

2. Click Edit. The Edit Reader window opens. 

 
3. Change the description. 

4. Click OK. 

4.4.3 Deleting an Existing Reader 

To delete an ex isting reader: 
1. From the Readers list, select a reader. 

2. Click Delete. A confirmation message appears. 

3. Click Yes to confirm. 
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5. File Menu 
DigiTool Reports Lite software has an integrated database that stores all of the 
data downloads from the GC-01 reader tours. This database interfaces to the 
user in the software for printing customized and standard reports, or for 
exporting the data to other applications. 

The GS-01 software package has a pulldown File menu, which allows you 
manage the integrated database. 

Figure 6: File Menu 

 
The File menu includes the following options: 

 Archive Events 

 Backup 

 Restore 

5.1 Archive Events 

This option allows you remove a selected range of events (by date) from the 
reader and save them to a text file. 

To archive events: 
1. Click File > Archive Events. The Archive Event Data window opens. 
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2. Choose the Start Date and End Date from the dropdowns. 

3. Click OK. 

4. A warning message appears. 

 
5. Click Yes. 

A standard Save As window opens. 

 
6. Choose Save to use the default location or browse to a new location. 

7. A confirmation message appears. 

 
8. Click OK. 
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5.2 Backup 

DigiTool Reports Lite software has an integrated database, which stores all of 
the data downloads from the GC-01 reader tours. This database interfaces to 
the user in the software for printing customized and standard reports, or 
exporting the data to other applications. 

This option allows you to save all data saved on the reader to a file on your PC 
as a backup file. 

 

You will need Microsoft Access or the equivalent to open the saved file. 

To back up your data: 
1. Click File > Backup. The Select backup destination window opens. 

 
All new data is added to the existing data and accumulates on the hard drive 
as a database file. We recommend periodical archiving of the old database in 
this software to minimize the size of the data file stored onto the hard drive. 
After the data becomes redundant, you may select the Backup Database 
selection from the Tools menu to Archive the database. 

2. Select the location where you wish to save the file. 

3. Click Save. 

The backup file is saved to the specified location. 

4. Click OK to confirm. 
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5.3 Restore 

In addition to being able to back up your database, you can also restore the 
data to the reader from the backup file. 

To backup your data: 
1. Click File > Restore. The Select location of backup database file window 

opens. 

 
2. Browse to your archived database, on the hard disk, and click Open. 

The following warning message appears: 

 
3.  Click Yes to the confirm message. 
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6. Tools Menu 
The GS-01 Software package has a pulldown Tools menu to allow you to 
manage various reader and software settings. 

Figure 7: Tools Menu 

 
The Tools menu includes the following options: 

 Reader Options 

 Erase Reader 

 Reader Firmware Version 

 COM Options 

 User Maintenance 

 Company Information 

 Language 

6.1 Reader Options 

The GC-01 readers are programmable by the PC software, and can sync with 
the PC software. With is option, you can set the general settings of the reader. 

 

Please make sure the reader is docked in the base when programming it. 

To set the reader options: 
1. Click Tools > Reader Options. 

2. Set the reader to flash its LED, buzz, and/or vibrate during operation. 

 

The LED and vibration are suggested in high noise environments, while the LED 
is suggested at night. 

3. Set the buzzer duration to Short (1 second) or Long (2 seconds). 

4. Set the time and date. 

5. Select or clear the Automatically Set Time and Date to PC’s settings 
when downloading data checkbox as desired. 

6. Click Send. 
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6.2 Erase Reader 

The GC-01 data reader can read up to 8000 locations and events in it internal 
memory, and these events are downloaded onto the PC software database for 
analysis and reports generation. 

Use the Erase Reader option if you wish to delete the contents of the data in 
the reader without downloading it to the PC. 

To erase the reader’s data: 
1. Click Tools > Erase Reader. A confirmation window opens. 

 
2. Click Yes. 

Once the reader’s data is cleared, the following confirmation is displayed. 

 
 

 

During this time, please do not remove the reader from the docking base, until 
the task has been finished, otherwise this may damage the system. 

If there is a failure, the following message is displayed. 

 

6.3 Reader Firmware Version 

This option allows you to see the firmware version installed on the reader. 

To see the firmware version: 
1. Place the reader in the docking station. 

2. Click Tools > Firmware Version. 
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A window opens showing the firmware version. 

 

6.4 COM Options 

With this option, you can choose the serial port connected to the PC. 

To set the com port: 
1. Click Tools > Com Options. The Communications Setup window opens. 

 
2. Choose the Com port that the reader is connected to. 

3. Click OK. 

6.5 User Maintenance 

As mentioned in Section  3.1, you can log in to the system as either as Master 
or as User. The User Maintenance option allows you to change the password 
for either of these user levels. 

To change the Master login password: 
1. Click Tools > User Maintenance > Master. The User Maintenance - 

Master window opens. 
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2. Enter the new password (case sensitive), and then re-type the password to 
confirm. 

 
To change the User login password: 
1. Click Tools > User Maintenance > User. The User Maintenance - User 

window opens. 

2. Enter the new password (case sensitive), and then re-type the password to 
confirm. 

 
6.6 Company Information 

In the Company Info menu, you can enter information (such as name and 
address) that will be printed as a header on all of the reports generated by the 
software. 
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6.7 Language 

With this menu option, you can choose the language of the GUI interface. 
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7. Downloading Data from Reader 
Once the system is set up, it is the time to gather data on the GC-01 reader by 
following tours, or just performing the rounds. The data in the reader can only 
be downloaded to the software if the reader has been enrolled properly 
(Section  4.4). 

7.1 Making Tour Rounds 

To collect data on a tour: 
1. Clear the reader to ensure there is no old data. 

2. Start the tour by going to Location 1 and reading the location tag. 

3. After the first location, if there are events, read the corresponding events 
into the reader. 

4. Repeat Steps  2 and  3 for each additional location. 

The GC-01 reader can accommodate 8000 reads in the memory with the 
associated time and date stamps. 

7.2 Downloading the Reader to the PC 

Once all the relevant data has been accumulated on the GC-01 reader, you 
can download the data to the PC to store the raw data database and to later 
generate reports. 

To download data from the reader: 

1. Click the Download icon ( ) on the main toolbar. The Download screen 
appears. 
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2. Place the GC-01 reader in the GC-02 docking station. 

3. Click Download Data. The system starts to download data from the GC-
01 reader. 

When all data has been downloaded, the data is displayed in the 
Download window. 

 
The GS-01 software displays all of the locations and events that occurred as 
presented in the reader. 

This information is shown only for the current download session and the data 
is placed in the database. Any time new data is downloaded to the system, the 
raw data is shown on the screen; otherwise, this screen remains empty. 

After each time the data is successfully saved to the database, the data is 
erased from the reader automatically. This prevents the system from having 
any redundant data. 

7.3 Erasing Data from the Reader 

If you wish to erase data from the reader without downloading the data, you 
can click Erase Reader in the Download window or from the Tools menu 
(Section  6.2). In both alternatives, the reader must be docked in the GS-02 
docking station. 
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8. Reports Wizard 
The DigiTool Reports Lite software can generate a variety of reports for the 
data recorded by the reader and saved to the database (Figure 8). 

Figure 8: Reports Window 

 

8.1 Generating Reports 

The following kinds of reports can be generated: 

 Tour/Exception Report 

 Incident Report 

 Incident Report with Sites 

 Reader Download Report 

 Hardware List Report 

 Patrol Schedule Report 

 Database Report 

8.1.1 Tour/Exception Report 

This report shows either all tour points or only the exceptions from the tours, 
which includes missed points and early or late arrivals to locations. You can 
also choose whether or not to include events. 
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To generate a Tour/Exception Report: 

1. Click the Reports icon ( ) on the main toolbar. The Reports screen 
appears. 

2. Double-click the Tour/Exception Report row in the main screen. 

The Tour/Exception Report window opens. 

 
3. From the Tour dropdown, select the desired tour. 

4. From the Reader dropdown, select the reader. 

5. From the Tour Date dropdown, select the date of the tour. 

6. Select whether you wish to show all tour points or only exceptions. 

7. Select the Include Events checkbox if you wish the report to include 
events. 

8. Click Print Preview. 

The report is generated and opens in a new window. 

8.1.2 Incident Report 

The Incident Report is a report that focuses on the events that are recorded in 
the system software. This report sorts the events between the specified dates, 
according to the individual event type (user specified) and the reader (user 
specified) and the site. 

The report can be printed according to each individual event, reader and site, 
or can present the data for all sites, or all readers, or all events. 
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To generate an Incident Report: 
1. Double-click the Incident Report row in the main screen. 

The Incident Report window opens. 

 
2. Specify the data range for the report using the Start/End Date 

dropdowns and the Start/End Time spin boxes. 

3. In the Readers section, choose the readers for which you want to generate 
a report. 

4. In the Events section, choose the relevant events. 

5. Click Print Preview. 

The report is generated and opens in a new window. 
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8.1.3 Incident Report with Sites 

This report is similar to the Incident Report, but adds a filter of sites in addition 
to readers and events. 

To generate an Incident Report with sites: 
1. Double-click the Incident Report with Sites row in the main screen. 

The Incident Report with Sites window opens. 

 
2. Specify the date and time range for the report using the Start/End Date 

dropdowns and the Start/End Time spin boxes. 

3. For each of the Event, Reader, and Site dropdowns, choose the relevant 
event, reader, or site, respectively, or choose All where desired. 

4. Click Print Preview. 

The report is generated and opens in a new window. 
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Above is an Example of an Incident Report, for Event 1, for all readers and all 
sites. 
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8.1.4 Reader Download Report 

The Readers Download Report provides a complete record printout of the 
downloading activity and the data content entered into the database at each 
download. 

To generate a Reader Download Report: 
1. Double-click the Reader Download Report row in the main screen. 

The Reader Download Report window opens. 

 
2. From the Reader dropdown, choose the reader. 

3. Specify the date and time range for the report using the Start/End Date 
dropdowns and the Start/End Time spin boxes. 

4. Click Print Preview. 

The report is generated and opens in a new window. 
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8.1.5 Hardware List Report 

This report provides a full list of the installed hardware on the system including 
location tags, event books, and readers. 

This report is not dependent on the date and time, only on the type of 
hardware selected to be reported. 

To generate a Hardware List Report: 
1. Double-click the Hardware List Report row in the main screen. 

The Hardware List Report window opens. 

 
2. From Location, Event, and Reader, select for which type of hardware 

you wish to generate a report. 

3. Click Print Preview. 

The report is generated and opens in a new window. 
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8.1.6 Patrol Schedule Report 

This report displays the schedule of the tour for the reader users including 
description, site where the location is placed, and a Target time. In addition to 
the Target time for the visit to the locations, there is a window of time where a 
location visit is acceptable. Any visits that do not comply with the schedule are 
shown on the Tour/Exception Report. 

To generate a Patrol Schedule Report: 
1. Double-click the Patrol Schedule Report row in the main screen. 

The Patrol Schedule Report window opens. 

 
2. From Location, Event, and Reader, select for which type of hardware 

you wish to generate a report. 

3. Click Print Preview. 

The report is generated and opens in a new window. 
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8.1.7 Database Report 

The Database Report lists all of the locations and events as they occurred at the 
reader between the pre-set dates. 

To generate a Database Report: 
1. Double-click the Database Report row in the main screen. 

The Database Report window opens. 

 
2. Specify the date and time range for the report using the Start/End Date 

dropdowns and the Start/End Time spin boxes. 

3. You can also use the Presets buttons to help specify the date and time 
range. 

4. Click Print Preview. 

The report is generated and opens in a new window. 
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8.2 Printing and Exporting Reports 

Once a report is generated, a window opens showing the print preview of that 
report. In each of these print preview windows, a toolbar appears at the top 
left. 

 
To print a report: 

1. Click the Print ( ) icon. A standard Print window opens. 

To export a report: 

1. Click the Export ( ) icon. A standard Export window opens. 

2. Enter a file name for the export file. 

3. Choose the location where you wish to save the export file. 

4. Click Save.
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A. DigiTool Care and Maintenance 
This chapter presents a few warnings when using and handling the various 
DigiTool pieces of equipment. In addition, the DigiTool components require a 
certain amount of care when in use for long periods, which is described here. 

A.1 GC-01 DigiTool ID TAG Reader 

A.1.1 Warnings 

 Do not disassemble, incinerate, or erode this product. All service shall be 
done in an authorized Rosslare service center. Any tampering will void the 
warranty. 

 Do not apply any voltage through the contacts at the head of the reader 
as this may damage the unit. 

A.1.2 Cleaning 

When in use over long periods of time, dirt or dust may accumulate on the 
head. Clean the contacts using a wet cotton swab. Wipe the exterior with a 
damp cloth. 

A.2 GC-02 DigiTool Docking Base/PC Interface and Charger 

A.2.1 Warnings 

 Do not disassemble, incinerate, or erode this product. All service shall be 
done in an authorized Rosslare service center. Any tampering will void the 
warranty. 

 Do not apply any voltage through the contacts at the head of the reader 
as this may damage the unit. 

 The unit is not water resistant. When inserting a GC-01 into the GC-02, 
make sure it is very dry. 

 Do not tamper with the contacts, as this may cause undesired function. 

A.2.2 Cleaning 

When in use over long periods of time, dirt or dust may accumulate on the 
body. Clean the exterior using a damp cloth. Remove dust using a small dry 
brush. 

A.3 GA-01 DigiTool Location Tag 

A.3.1 Warnings 

 Do not disassemble, incinerate, or erode this product. All service shall be 
done in an authorized Rosslare service center. Any tampering will void the 
warranty. 

 Do not destroy, dent or hammer on the GA-01 button as this may 
damage the button. 
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A.3.2 Cleaning 

When in use over long periods of time, dirt or dust may accumulate. Clean 
using a wet cotton swab. 

A.4 GA-02 DigiTool Event Book 

A.4.1 Warnings 

 Do not disassemble, incinerate, or erode this product. All service shall be 
done in an authorized Rosslare service center. Any tampering will void the 
warranty. 

 Do not dent or hammer on the GA-01 button as this may damage the 
button. 

A.4.2 Cleaning 

When in use over long periods of time, dirt or dust may accumulate. Clean 
using a wet cotton swab. 
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